Home Assistant – Browserbasierte Konfiguration

In diesem Artikel zeige ich Dir, wie Du deine Home Assistant Umgebung per Browser konfigurieren kannst. 

Wie bereits in der Einführung beschrieben, erfolgt die Konfiguration in der Regel per SSH oder FTP-Zugang direkt auf dem entsprechenden Home Assistant System (z.B. auf einem PI). Mit einem Addon kann die Konfiguration aber auch komfortabel direkt im Browser verändert werden.

Im ersten Schritt melden wir uns nun an Home Assistant an und öffnen im Menü den Bereich „Hass.io“. Nun wechseln wir auf den Menüounkt „ADD-ON STORE“. In diesem Bereich finden wir in den offiziellen Addons den „Configurator“.

 

 

Auf der Informationsseite des Addons können wir nun die Installation beginnen sowie das Addon konfigurieren. Hier können wir zudem hinterlegen, dass das Addon direkt beim Boot gestartet werden soll.

 

 

Für die Konfiguration muss ein Benutzername und Passwort hinterlegt werden.

 

Nach dem wir nun die Installation und Konfiguration abgeschlossen haben, können wir das Addon im nächsten Schritt starten. Nach dem das Addon gestartet wurde, können wir über die Schaltfläche „Open web UI“ unten rechts den Konfiguration starten.

 

 

In der Konfiguration können wir nun die Home Assistant Konfiguration „/config/configuration.yaml“ bearbeiten.

 

 

Über die Browse-Schaltfläche oben links kann die Verzeichnisstruktur eingeblendet werden.

 

 

Matthias Korte

Hauptberuflich Software-Entwickler und seit einigen Jahren Smart-Home Fan. Angefangen hat alles mit einem RaspberryMatic und einer schaltbaren Steckdose. Mittlerweile habe ich einige Steckdosen, Sensoren, und Thermostate sowie ioBroker zur Visualisierung im Einsatz.

2 Gedanken zu „Home Assistant – Browserbasierte Konfiguration

  • 19. Februar 2021 um 19:43
    Permalink

    Ich habe mir gerade den „File Editor“ (=Configurator) installiert.

    Ein Benutzername und Passwort brauchte ich nicht eingeben.

    Allerdings ist mir aufgefallen, dass er regelmäßig sich immer neu „lädt“ und damit die gerade vorgenommenen Einstellungen weg sind… wenn man nicht alle 1-2 Min. speichert.

    Hast Du dafür eine Erklärung oder Lösung?

    (Habe mein HA gerade erst neu aufgesetzt.)

    Antwort
    • 21. Februar 2021 um 19:36
      Permalink

      Hallo Matthias,

      das Problem kenne ich so leider nicht, muss mal schauen ob das bei mir in der neuesten Version auch passiert.

      LG Matthias

      Antwort

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.