ConBee II Zigbee USB-Gateway – Teil 8 – Aqara Switch anlernen und auf Events reagieren

In dieser Artikelreihe schauen wir uns gemeinsam das ConBee II Zigbee USB-Gateway an und lernen einen Xiaomi Button an die Software an.

Mit dem ConBee II Zigbee USB-Gateway können wir herstellerübergreifend Zigbee-Devices ohne eigenes Gateway/Bridge und ohne Cloud in unser Smart-Home integrieren. Im 8. Teil der Artikelreihe werden wir nun einen Aqara Switch (6-Fach) anlernen und auf die verschiedenen Ereignisse in ioBroker reagieren.

Der ConBee II kann entweder direkt beim Hersteller oder auch z.B. bei Amazon erworben werden.

Link zum Shop des Herstellers:

https://phoscon.de/de/shop/conbee2

ConBee II bei Amazon:

ConBee II das universelle Zigbee USB-Gateway

Preis: 39,95 €

1 gebraucht & neu ab 39,95 €

Den Aquara Switch bekommst Du bei Amazon (wenn es schnell gehen soll). Ansonsten ist er auf ebay.de ein wenig günstiger zu haben.

Wir starten jetzt mit dem Anlernen von neuen Geräten an unseren ConBee II USB-Gateway. Dazu melden wir uns wieder an der ConBee App über den Browser an und geben das von uns definierte Kennwort ein.

Nach der Anmeldung gelangen wir in die App, in der wir zunächst über den Sandwich-Button oben links in die Einstellungen wechseln.

In den Einstellungen klicken wir im Bereich Geräte – Schalter auf die Schaltfläche Neuen Schalter verbinden. Auf der Ansicht kannst Du verschiedene Hersteller auswählen. Aqara ist hier derzeit nicht vertreten, daher klickst hier auf Andere.

Jetzt nimmst Du den Schalter aus der Halterung und klickst auf der Rückseite die Connect-Schaltfläche für ca. 5 Sekunden. Achte darauf, dass nun die Status-LED auf der Vorderseite des Gerätes einige male blinkt.

Bei mir hat das Anlernen des Schalters beim ersten mal direkt geklappt, der Schalter taucht nun in der Liste der verbundenen Schalter auf.

Über die Details sehen wir hier nochmals weitere Informationen des Schalters.

Im nächsten Schritt schauen wir uns nun noch die ioBroker Integration an. Die Schalter werden unter den Sensoren aufgelistet. Hier gibt es wieder einen zentralen Datenpunkt, in dem der zuletzt gedrückte Button-Code steht. Zudem gibt es für jeden einzelnen Schalter noch einen Kanal, in dem die einzelnen Schaltzustände zu finden sind. Jeder Schalter unterstützt dabei einen einfachen, doppelten und langen Tastendruck.

Im folgenden Foto siehst Du die verschiedenen Tasten mit den jeweiligen Tasten-Codes. Das (k) steht für kurzer Tastendruck, (l) für langer Tastendruck, (lr) für das loslassen beim langen Tastendruck und das (d) für einen doppelten Tastendruck.

In den Objekten siehst Du die folgende Ansicht:

Zudem gibt es für jeden Schalter noch extra Datenpunkte, welche die einzelnen Schalter-Zustände darstellen. Die Datenpunkte werden erst angelegt, wenn alle Schalter mit kurzem, doppelten und langen Tast-Vorgängen betätigt wurden.

Ich hoffe euch gefällt dieser Artikel. Über Kommentare unterhalb des Artikels oder per E-Mail freue ich mich wie immer.

Matthias Korte

Hauptberuflich Software-Entwickler und seit einigen Jahren Smart-Home Fan. Angefangen hat alles mit einem RaspberryMatic und einer schaltbaren Steckdose. Mittlerweile habe ich einige Steckdosen, Sensoren, und Thermostate sowie ioBroker zur Visualisierung im Einsatz.

20 Gedanken zu „ConBee II Zigbee USB-Gateway – Teil 8 – Aqara Switch anlernen und auf Events reagieren

  • 1. August 2020 um 17:55
    Permalink

    Ich habe den Taster bei mir erfolgreich integrieren können.
    Jedoch habe ich das Problem, wenn ich auf „hold“ triggern möchte und die Taste (egal welche) länger als ca. 5sek der Status „true“ nicht mehr zurückgesetzt wird.
    Hat jemand eine Idee wie ich diesen Fehler beheben könnte?

    Antwort
    • 4. August 2020 um 21:26
      Permalink

      Hallo David,

      ja das habe ich auch festgestellt. Ich verwende daher direkt den ButtonCode Datenpunkt und frage hier die einzelnen Codes ab.

      LG Matthias

      Antwort
  • Pingback: Aqara Opple Schalter in Jung-Rahmen einbauen – smarthome-tricks.de

  • 3. September 2020 um 13:57
    Permalink

    Spannender Artikel, Danke!

    Kannst Du etwas zu Homekit Integration schreiben?
    Geht das mit Homebridge, evtl. sogar auf dem gleichen Raspi?

    Danke

    Antwort
  • 29. September 2020 um 21:05
    Permalink

    Hallo Matthias,

    wieder ein toller Artikel.
    Mein 3/6-fach OPPLE ist heute auch gekommen und konnte problemlos angelernt werden.
    Dabei habe ich festgestellt, dass es auch ein triple-press-event gibt (Endziffer 5).
    Das macht ja theoretische 18 mögliche Geräte zu schalten/umzuschalten. Ich bin begeistert.

    Grüße

    Antwort
  • 7. Oktober 2020 um 14:25
    Permalink

    Hi Matthias,

    sie Beschreibung ist wieder erstklassig und trotzdem bekomme ich den Opple nicht angelernt. Er erscheint weder in Phoscon, noch in den Deconz Objekten. Ich habe auch den Conbee II mal abgezogen und die Instanz neu gestartet. Kein Erfolg.
    Hat der von Dir verwendete Schalter auch mit kinetischer Energie funktioniert oder gibt es da noch eine batteriebetriebene Version? Welche Deconz Adapterversion hast Du genutzt? Laut Adapterbeschreibung ist der Opple kompatibel.
    Ich bin etwas ratlos…

    Greetz
    Roland

    Antwort
    • 30. Oktober 2020 um 19:43
      Permalink

      Der Aqara Opple 3/6fach Schalter hat eine Batterie CR2032. Man kann die 3 kleinen Frontplatten vorsichtig entfernen mit einem Kunstoffteil zB Gitarrenplektrum. Dann die sichtbare Kunststoffplatte abschrauben, Auf der rückseite der dann freiliegenden Platine sitzt die Batterie. Wenn die nicht mehr voll ist, lässt sich der Schalter nicht anlernen! Ich hatte auch Probleme, die erst durch Batteriewechsel gelöst werden konnten.

      Antwort
  • 10. November 2020 um 6:16
    Permalink

    Hallo,
    der deconz Datenpunkt „buttoevent“ liefert bei mir bei langem „drücken“ den Code 1001.
    Beim „loslassen“ erhalte ich keinen Code 1003.
    Nach meinem Verständnis müsste diese aber so sein?
    Ist dies nur ein Problem bei mir? Oder verhält sich der Schalter/deconz überall so?

    Antwort
    • 10. November 2020 um 6:35
      Permalink

      Moin,
      ja, so ist es bei mir auch. Langes drücken 1001, loslassen dann 1003. Wie lange hast Du gedrückt?

      Antwort
  • 10. November 2020 um 7:42
    Permalink

    Ich drücke einige Sekunden (verschiedene Dauer probiert). x001 kommt auf allen Tasten. x003 kommt nie. Nur x002 bei kurzem drücken.
    Ich hatte in node-red einen One-Button-Dimmer mit 1001 für Start und 1003 für Stop probiert.
    Dabei ist mir dann aufgefallen, dass der Code x003 nicht gesendet wird.

    Ich habe zwei Schalter. Beide zeigen das gleiche Verhalten.

    Antwort
  • 15. November 2020 um 19:10
    Permalink

    Hallo,
    wird die 1003 dir gesendet? Falls ja, welche Software Version verwendest Du?
    Gruß
    Stefan

    Antwort
  • 29. Dezember 2020 um 13:09
    Permalink

    Moinsen, grade auch einen von den 6 fach Aqara Opple bekommen, anlernen ging beim zweiten Versuch dann ohne Probleme.
    Jedoch schalten jetzt einzelne bereits vorhandene Endgeräte OHNE dass irgendwas eingerichtet wurde beim druck auf eine der oberen beiden Schalter.
    Auch in Phoscon sind sie keiner Gruppe als Schalter zugewiesen….spielt grade alles bisschen verrückt hier. Ne Idee woran das liegen könnte?

    Antwort
  • 29. Dezember 2020 um 14:50
    Permalink

    Mein vorheriger Kommentar kann gern gelöscht werden.
    Anscheinend funktioniert der Opple Switch aktuell NUR mit der 2.05.84 Version. Alle neueren Versionen lassen ein koppeln nicht vernünftig zu und die Buttons 1 + 2 schalten (fast) alle Aktoren im Zigbee Netz einfach ein und aus.

    Antwort
  • 1. Januar 2021 um 15:06
    Permalink

    Derzeit nutze ich die deConz Version 2.07.01 und die Firmware 26580700 des ConBee II. Der erste Opple 3-fach-Switch läuft damit seit etwa zwei Wochen ohne Probleme. Beim Versuch, einen weiteren 3-fach-Switch zu verwenden, erlebe ich das gleiche Fehlerbild wie Bjoern: Der Switch schaltet einfach alles, was ihm über den Weg läuft. Es überrascht mich, dass das Fehlerverhalten in älteren und in neueren Versionen auftritt, aber „dazwischen“ bei 2.05.84 nicht.

    Antwort
  • 2. Januar 2021 um 19:09
    Permalink

    Mit der deConz Version 2.05.84 tritt das Fehlerverhalten, dass er alle am Gateway angeschlossenen Lampen und Aktoren schaltet, auch bei mir nicht mehr auf. ABER: Unter 2.05.84 kann ich dem Schalter keine Funktionen „an bzw. hochdimmen“ und „aus bzw. runterdimmen“ zuweisen. Es stehen lediglich die Funktionen „an“, „aus“, „x% hochdimmen“ und „x% runterdimmem“ zur Verfügung. Nicht nur, dass so der Dimmvorgang unhandlich wird (mehrmals einzeln tasten statt dauernd tasten), es werden auch doppelt soviele Tasten für an/aus/dimmen benötigt. Das kann also (für mich) keine Lösung sein.

    Mit neueren deConz-Versionen bis hoch zur Beta 2.09.00 und mit neueren Firmware-Ständen bis hoch zur Beta 26680700 kann ich den Schalter (sogar recht schnell) mit dem Gateway paaren. Aber in all diesen Fällen schaltet er alle verfügbaren Lampen und Aktoren (sogar im ungepaarten Zustand!). Der erste Opple 3-fach-Schalter arbeitet dabei einwandfrei. Nur der zweite Opple 3-fach-Schalter „spinnt“.

    Antwort
    • 3. Januar 2021 um 8:41
      Permalink

      Moin,

      vielen Dank für den Link zur Lösung 🙂

      LG Matthias

      Antwort
  • 21. Januar 2021 um 16:40
    Permalink

    Mittlerweile habe ich sechs Opple 3-fach-Switches erfolgreich im Einsatz. Einen Opple 1-fach-Switch habe ich bisher jedoch noch nicht pairen können (https://de.aliexpress.com/item/4001154276289.html). Auch wenn ich mehrere Sekunden lang den Reset-Button an der Rückseite des Schalters drücke, fängt die Leuchte auf der Vorderseite oben links nicht an zu blinken. Viele Versuche habe ich schon gemacht, alle vergebens. Raspberry- bzw. Conbee-Restarts haben keine Besserung gebracht.

    Hat schon jemand von Euch den Opple 1-fach-Switch erfolgreich zum Laufen gebracht? Wenn ja: Wie?

    Antwort
  • 22. Januar 2021 um 11:15
    Permalink

    Das ist schon ein richtiges Ärgernis! Zwei nietnagelneue Opple 1-fach-Switches gekauft. Keiner von beiden war paarungswillig. In beiden Switches neue Batterien eingesetzt, schon waren die beiden in Sekundenschnelle mit dem Gateway gepaart. Ein Blick ins Internet zeigt, dass ich nicht der einzige bin, dem dieses Ärgernis widerfahren ist. Also: Falls beim Drücken der Reset-Taste von Opple Switches nach einigen Sekunden das Kontrolllämpchen nicht flackert, gleich eine neue Batterie einsetzen. Wie das geht, zeigt uns Tante YouTube: https://www.youtube.com/watch?v=HC41WsIPzmQ

    Antwort

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.